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Getting started

Compatibility

* This version of Discover can analyse files from Acquire™” 2023R1 or earlier and saved results from
Discover™ 2023R1 or earlier.

» TDMS files are no longer supported. Refeyn’s tdms_to_mp_converter application can be used to con-
vert TDMS files into .mp files.

Installing/updating

If installing Discover™" for the first time, jump to step 4.

1. Make sure all instances of Discover™? are closed.

2. Uninstall the old version of Discover™ by going to Control Panel > Programs > Programs and Features
and then selecting Discover™ to uninstall.

3. Check the uninstall has been successful by going to C:\Program Files (x86) in the Windows file explorer
and checking that there is no folder called DiscoverMP. If there is, manually delete the folder.

4. Execute the Discover™? setup executable file (the filename will be like: DiscoverMP_v0.0.0_setup.exe).
Double clicking on the file will bring up an install wizard.

5. Follow the steps of the installer, making sure to read the terms and conditions before accepting.

6. Once the installer has been completed, the software is ready to use.

Multiple displays

When using multiple displays, the settings must be correct to avoid issues with the application’s layout. The
most common issue comes from having different zoom factors for each display. To make sure this does not
happen, each display must be set to the same zoom factor. The image below depicts the setting that must be
the same for each display (and ideally set to 100%).

Settings field that
must be the same
for all displays

Figure 1: Multiple displays

Refeyn Discover™” User Manual ¢ Page 4



Licensing

When you open the application for the first time the program will prompt you to activate your licence with
your licence key. The licence key is normally provided with the software, and looks like ABCDE-FGHIJ-
KLMNO-PQRST. If you do not have a licence key, one can be obtained by contacting Refeyn using sup-
port@refeyn.com.

If the PC on which you are installing Discover™ has an internet connection, make sure Use this PC’s
internet connection is selected, then simply enter the licence key into the box and click OK.

If the PC does not have an internet connection or the connection fails, choose Use another PC’s internet
connection, then enter the licence key into the box, click Next and note down the machine code shown in
the dialog. Next, on a different PC with an internet connection, open the webpage shown in the dialog. This
will load a form in which you should enter the machine code and your licence key. On clicking Activate, an
.skm activation file will be downloaded. Copy this file onto the PC on which you wish to install Discover™P.
Enter your licence key into the Discover'™ dialog and use the Browse button to select the .skm activation
file you copied over, then click OK. Discover™® will now load.

Deactivating the licence

If you wish to move your licence for Discover™ to another PC, you should deactivate the licence on the PC
you no longer wish to use. To do this, open Discover™ and go to Help > Deactivate licence. A warning
message will be shown. Clicking Yes will close Discover™ and deactivate the licence on that PC. You can then
activate your licence key on another PC. To reactivate a licence after deactivating it, simply open Discover™?
again and re-register the licence, following the instructions above.

Main user interface panels

Figure 2: Main panels for data analysis
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Figure (1)

Mass [kDa]

Figure 3: Figures Panel

Table (1)

1: Mass position (kDa 1: Mass sigma (kDa) 1: Mass absolute count 1: Mass relative count
e Sat e - Gaussian Overlay - Gaussian Overlay - Gaussian Overlay - Gaussian Overlay

487 2 8

Figure 4: Tables Panel

Managing a workspace and measurement files

Opening and closing a workspace

When opening Discover™P, the user will have access to a workspace where multiple files can be visualised and
analysed. To analyse a measurement file, just add it to the workspace and the analysis will start automatically.
There are three main types of measurement files that can be added to a workspace:
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* A recording file (.mp) or a mass photometry results file (.mpr) saved in Acquire™”

* A mass photometry results file (.mpr) saved (or exported) in Discover™ v2.5 or later
* A legacy results folder saved in Discover™” v2.4 or earlier

To open a previously saved workspace, go to File > Open Workspace and select the workspace file
(.dmp) of interest. This will open all measurement files, analysis and data associated with this workspace.

To close a workspace, go to File > Close Workspace.

Managing files in a workspace
Adding files
To add a recording file (.mp) or mass photometry results file (.mpr) to a workspace press the + button on

the top-left corner of the Files Panel. Alternatively, when Discover™ is first opened, there is also a + button
in the central panel (see Figure 5 below). This opens a file explorer dialog.

Figure 5: Main window when first opening application

Once a measurement file has been selected, the data is loaded into the application. If the measurement file is
large, this may take a while to load.

After loading, the analysis of recording files (.mp) will start automatically. Files will be analysed one at a time
in the order in which they were added to the workspace. While the file is being analysed, the background
for that measurement will turn into a progress bar. Mass photometry results files (.mpr) will be immediately
available after loading.

To add a legacy results folder to a workspace, go to File > Open Legacy Results, or click Ctri+Shift+O.
This opens a file explorer dialog, where the results folder can be selected.
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. The maximum number of measurements that can be added to a workspace is dependent on
__ the computer’s virtual memory. The more files added, the larger virtual memory required.
~ If your computer runs out of memory, some data might be lost. We suggest no more than

= 24 files to be added to a workspace.

’

Selecting and visualising measurement files

To select a measurement file, click on its name in the Files Panel. When selected, the measurement file’s name
will be highlighted in yellow. To visualise the data associated with a measurement file, double-click on the file’s
name and the data will be shown in the Analysis Panel.

Removing measurement files

Measurement files can be removed from a workspace by selecting them and clicking on the Bin icon at the
top-left of the Files Panel.

Merging measurement files

Measurement files can be merged in a workspace by selecting the measurements of interest and clicking on
the Merge icon at the top-left of the Files Panel. This will automatically generate a new measurement on the
workspace containing the merged data. Merged files will not have movie or movie scores data available. For
files to be merged, the device, measurement mode and image size need to be the same.

To enable mass mode for a merged measurement file, a mass calibration needs to be applied to each indi-
vidual measurement before the merge.

Data analysis

When a recording file (.mp) is added to a workspace, the file is automatically loaded and queued for analysis.
To stop the analysis, click on the Stop icon at the top of the Files Panel. The analysis can be started again by
clicking on the Start icon at the top of the Files Panel.

Analysis modes

When recording movies in AcquireMP there are three modes available, the Normal mode, the AAV mode
and the Samux mode. Depending on the mode used, the functionality available in the Analysis Panel associ-
ated with that measurement file will be different.

+ Normal mode: This is the default mode in Acquire™” for acquiring and analysing biomolecules when
using a One™P, Two™P, One™” Auto, Two™ Auto

« AAV mode: This is a special mode that can be selected in Acquire™” for acquiring and analysing AAV
samples when using a One™P, Two”MP, One™P Auto, Two™P Auto

+ Samux mode: This the default and only mode in Acquire™” for acquiring and analysing AAV samples
when using a Samux"?

Refeyn Discover™” User Manual ¢ Page 8



Normal Mode AAVY Mode Samux Mode

Acquisition movie X X X
Acquisition scores X X X
Histogram X X X
KDE X X
Contrast X X X
Mass X X X
Acquisition plot setup X X X
Vertical lines X X X
Interval regions X X X
Automated peak fitting X X
Manual peak fitting X X X
AAV limits X
Refining data options X X

Acquisition visualisation and editing tools

To visualise the data associated with the measurement file of interest, double click the file name on the File
Panel. The data will appear in the Analysis Panel.

Figure 6: Analysis Panel showing selected file

__ The measurement file displayed on the Analysis Panel will be highlighted in bold and have an
=/~ arrow pointing to the Analysis Panel next to the file name.
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Acquisition movies and scores

In the Analysis Panel, there are two different types of movies available, native and the ratiometric.

Native movies: Native data acquired using Acquire™”.

Ratiometric movies: During analysis the ratiometric images are calculated. This involves dividing future
(time-averaged) movie frames by past (time-averaged) movie frames. During each of these operations, the
data that is common to both images is removed, leaving only the difference between each of the pairs of
frames. This is the ratiometric image which in turn produces the ratiometric movie.

To see an overlay of the spatial distribution of all detected events, right-click on the movie panel and then
selecting Show > Distribution. A high quality measurement should give a roughly uniform spread across the
movie.

At the bottom of the movie panel, there are five options to choose from: Sharpness, Saturation, Bright-
ness, Signal and Motion. Swapping between these modes will display the corresponding value for each
frame in the movie.

The Sharpness value shows how precisely the sample was positioned and held in focus during the measure-
ment. The minimum recommended Sharpness value for the One™” and Two™ is 4%. Please note that the
value can be exaggerated by a dirty glass surface, giving the false impression that the sample is in focus. In this
case, the user is advised to move the coverslip to a clean region before starting the recording in Acquire™".
Additionally, the sharpness value tends to decrease slightly with image size because the illumination profile
is more uniform as the light is distributed over a larger area. During the recording of a movie, sharpness
tends to increase as particles bind to the surface. That is expected and no reason for concern. However, a
significant drop of the sharpness value usually indicates that the sample moved out of focus, which may impact

data quality.

The Signal value is indicative of the amount of change in the data. Frames with higher signal usually show
particle binding/unbinding events. For a movie containing only a buffer measurement, this value should be
0.06% or lower. Please note that the choice of image size influences the signal level. As the image size is
increased the same amount of light is distributed over a larger area and therefore per-pixel noise increases.
Hence, the signal level for a clean buffer will tend to be higher for larger image sizes.

The Saturation value shows the percentage of pixels in the movie that are saturated (i.e. overexposed).
Ideally, this graph will be a flat line sitting at 0%. A small percentage of saturated pixels is tolerable but the
saturation value should not exceed 0.5%.

The Brightness value shows how much light the camera has detected in relation to its saturation level. This
indicates how efficiently the dynamic range of the camera has been used. A high brightness value is desirable
to minimise shot-noise in the data.

The Motion value gives an indication of the amount of lateral motion detected during the acquisition of a
frame. The value is calculated from the frame data by determining the amplitude of the motion signature
in the ratiometric frame. Small-scale motions are tolerable, but values exceeding 14% are considered to be
considerable motion and may impact data quality significantly.

The frame shown in the movie panel can be changed by moving the vertical yellow cursor along the x-axis of
the frame index graph or by entering the frame number in the box located in between the frame index graph
and the movie panel. There is also the option to switch the units to seconds. This allows you to enter in a
time in the box in seconds as well as a playback speed.
\ ! 4
__ You can move forward and backward through the movie by hovering over the Frame Index
=/~ graph and using the mouse wheel.

’
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The movie can be played using the Play button. Playback can be sped up or slowed down by changing the
frames per second (FPS).

Analysis plot types
Histogram vs KDE

For both Normal and AAV modes, the main plot can be toggled between histogram mode and kernel density
estimate (KDE) mode. The buttons to switch the mode are found in the histogram variables panel, labelled
Histogram and KDE. If you want the KDE mode to show an estimate of a Probability Density Function, then
check the Normalise button (the y-axis will be labelled “Normalised density”). For Samux mode, only histogram
mode is available.

Contrast vs mass

The histogram may be alternated between showing contrast and mass (kDa) on the X axis by selecting the
relevant plot in the Histogram variables window. Before switching to mass mode, the user must provide
a suitable mass calibration (see the section in this manual on mass calibration).

Acquisition plot setup
Changing the limits

The plot axis limits may be altered in three ways:

* By manually changing the values shown below the plot
* By hovering over the histogram and using the mouse wheel:

— Scrolling changes the y-axis maximum

— Ctrl-scrolling changes the x-axis minimum

= Shift-scrolling changes the x-axis maximum

— Alt-scrolling translated the histogram along the X axis

* By clicking the two buttons next to the axis limit boxes to automatically set the axes to the maximum
values found in the data.
« '+ The X axis maximisation button locks the X value to always show the maximum value. So,
= = if other settings are changed, the counts/density axis will adjust to show all the data. The Y
- ¥ axis does not update in this way.

Bin width and bandwidth

In histogram mode, contrast values are binned into ranges of values (bins) and then summed within these bins
to calculate the number of counts shown on the histogram. The width of the bins can be varied by changing
the Bin width in the histogram/KDE variables panel. The histogram is always split into equal regions with the
size of the bin width. The bin width units are contrast value (in contrast mode) or kDa (in mass mode).

In KDE mode, bandwidth can be changed in the histogram/KDE variables panel. The bandwidth units are
contrast value (in contrast mode) or kDa (in mass mode).
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Figure 7: Two histograms of the same data with bin widths of 8kDa (left) and 16kDa
(right)

Figure 8: Two KDE plots of the same data with bandwidths of 8kDa (left) and 16kDa
(right)

Normalise

The counts data can also be normalised by selecting the Normalised check box. This will divide the counts
in each bin by the total number of events. This facilitates easier comparison between histograms with differing
total numbers of events. In KDE mode, this button switches between plotting counts density (where the
area under the graph equals the number of counts) and plotting normalised density (where the area under the
graph equals 1, giving a probability density function).
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Figure 9: Histograms displaying counts (left) and normalised counts (right)

Vertical lines

When the Vertical lines button is selected, vertical lines can be added to the plot by double clicking with
the left mouse button on the plot or by dragging with the left mouse button. In addition to the vertical line, a
label will be added displaying the contrast/mass value. Dragging will draw a line at the median of the selected
values (no line is drawn if there are no counts in the region).

The labels generated from vertical lines can be moved to more favourable positions by dragging them with the
mouse. To delete a label and its corresponding vertical line, either select the label with the mouse and press
delete, or click the label while holding the shift key.

In KDE mode, the automatic peak selection becomes enabled. Pressing this adds vertical lines with labels at
each local maximum of the KDE plot.

The contrast values of all vertical lines are automatically entered into the table of the mass calibration dialog.
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Figure 10: Vertical lines displayed on both a histogram plot and a KDE plot

Interval regions

Adding interval regions to the plots provides information about events in the selected contrast/mass interval.
To add an interval region, click the Interval region button and drag with the left mouse button over the
desired interval. The selected region will then be highlighted and bound by pale yellow lines. Alternatively,
double-click on a peak to automatically fit a normal distribution and add an interval region about the detected
peak. The fitted region will be centred about the peak with bounds of +/- 2c. A label will also be displayed
which gives the median value of the region, the contrast/mass bounds for the region and the total number
of counts for the region displayed as a an absolute number and as a percentage value compared to the total
count of binding/unbinding events (depending on whether the interval covers binding or unbinding events).

The labels generated from interval regions can be moved and deleted in the same way as for vertical lines.
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Figure 11: Interval regions displayed on both a histogram plot and a KDE plot

Peak fitting

Peak fitting can only be used in histogram mode. Fitting a peak to the data provides information about peak
position, peak width, integrated counts, and skewness. Peaks can be fit automatically or manually.

Information about the fit is displayed above the curve in either contrast or mass units (depending on the
current mode). The information displayed is:

Mean peak value

Width of the fitted peak (o represents the standard deviation)

Sum of the number of counts under the fitted peak expressed as the number of counts and the propor-
tion of counts. (The proportion is defined as the number of counts compared to the total number of
binding/unbinding events depending on whether the peak is located in the binding or unbinding domain
of the histogram)

Pearson median skewness of the curve;

— Skewness = 0: the mean and median are the same; there is a normal distribution

— Skewness < 0: the mean is smaller than the median; the outliers of the distribution curve are
further out towards the left

— Skewness > 0: the mean is greater than the median; the outliers of the distribution curve are
further out towards the right

Automatic fitting

Once analysis of a measurement is complete, peaks will be added automatically to the data (except for
SamuxMP measurements). The peaks can be manually deleted as with all other peaks. If you have removed
your peaks, or you have a SamuxMP file, you can add the automatically generated peaks by pressing the Au-
tomatic peak fitting button located in the histogram toolbar.
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The automatic peak fitting can produce non-normally distributed peaks as it tries to fit to all of the data
present. The non-normally distributed peaks are easy to distinguish as they will have a non-zero skewness
value.

Manual fitting

To fit a Gaussian peak, either drag with the left mouse button over a contrast/mass interval or double click
near the centre of the desired peak.

More than one peak may be fitted at the same time by selecting multiple regions in the graph sequentially. If
a new region impinges on an existing Gaussian fit, the new peak fit will replace the previous one.

The labels generated from interval regions can be moved and deleted in the same way as for vertical lines.
\ ! 4
__ Avoid dragging the peak fit range across an adjacent peak as the fitting routine will only fit to
=~ the newly selected peak.

AAV limits

The AAV overlay contains four regions; empty, partial, full and overfull. The empty region (lower mass) should
be moved to cover the lower mass peak that represents binding events from empty capsids. The partial
region (between empty and full region) should be used if there is a clear mass peak in between empty and full
region that can be explained by partially filled capsids. The full region (higher mass) should be moved to cover
the higher mass peak which represents binding events from full capsids. The overfull region can be used to
accumulate all counts with a higher mass than the full region.

To enable the AAV limits, load a mass calibration (which must also come from a movie recorded in AAV mode)
and analyse the AAV movie in Discover™”. Once the movie is analysed, the histogram will automatically switch
to mass mode and add the AAV overlay.

The AAV overlays can be edited in multiple ways:

* By dragging either edge of the region you want to adjust

* By dragging the entire region that you want to move

* By manually adjusting the values that are visible beneath the histogram and are labelled AAV limits
* The partial and overfull region can be activated and deactivated accordingly

The AAV overlays can be saved and used in later sessions selecting the Save button on the AAV limits section.
AAV limits saved will be available on the drop-down menu above the AAV limits section.

When selecting Apply to all, the AAV limits selected will be applied to all measurements opened in the
current workspace.

The AAV overlay also has a label describing the details from the AAV overlay, which can be moved and deleted
in the same way as for vertical lines.
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3683 kDa
o146 kDa
635 counts (24%)}

Skewness: 0,000

Default

Create Mass Calibration

Figure 12: An example of an AAV movie with the AAV overlay added

Virus titer estimate

The rough titer estimation feature can be accessed by pressing the designated “Rough titer estimate” checkbox
within the software. This is only available with movies from a SamuxMP

Instructions for best results:

* The software is most accurate when used with samples that have a particle count between 500 and
1500 for a 1 minute movie

* Use a clean buffer without any surfactants or other inclusions to prepare the sample for analysis

Use (partially) purified samples

* It is recommended to repeat measurements to obtain a more accurate titer estimate
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Refining the data
The user can manually exclude movie frames and events that should clearly be omitted from the data analysis.
These may include frames where there has been a physical disturbance to the instrument, areas of the movie

image which display excessive underlying noise, and events that are clearly outside the expected range of
protein masses within an experiment. This functionality is only available for Normal and AAV mode.

Temporal selection

If there is a physical disturbance during movie recording, the movie may show high noise images. An example
of a noisy ratiometric frame is shown in Figure 13.

Native Ratiometric

-0.01000 - 0.01000

Sharpness Saturation Brightness

30

Time (s)

Frame Seconds , Speed 0.94

Figure 13: Frame index graph with removed frames indicated in purple and the time
mask tab showing the number of events included in the data

To exclude a number of frames, hold down the left mouse button and drag over the region to be excluded.
This action produces a purple overlay for the frames that are excluded and updates the selections panel to
reflect the excluded events.
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'
S ’ . .
_ @ _ As frames are excluded, the related event counts are removed from the histogram. It is a

=/~ good idea to watch the histogram to observe how much the plot changes.

’

The temporal mask can be deleted, either by right-clicking on the Frame Index graph and clicking Clear
Selection or by selecting Clear in the selections panel in the time mask tab. The mask can be inverted (using
the Invert button) so as to include only in the selected region(s) in the data analysis. The mask can be disabled
(i.e. shown but not applied) by unticking the Apply button.

Spatial selection

The aim of mass photometry experiments is to deliver meaningful movies for data analysis. However, on
occasion, there may be a region or small area of the movie image which shows high noise or is in some way
visibly erratic. Such an area can be removed using a spatial mask.

Figure 14: Image area selected for spatial masking shown in purple
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The spatial mask selection may be made on any frame by pressing and holding the left mouse button and
dragging over the region to be removed. This region will then be removed for all frames in the movie. Multiple
regions may be selected for spatial masking.

Similar to the temporal mask, multiple regions may be selected. The mask may be cleared, inverted and
disabled using the buttons in the selections panel.

The spatial mask tab holds information, including an indication of the number of events that are currently
selected and used for the histogram plot.
s~ When applying a spatial mask, the data points arising from that region of the movie are
= = removed from the histogram. If the spatial mask is inverted, the related data points are
’ N . .
- included and all other events (outside the mask) are removed.

The event distribution can be used to show potential regions to remove (found by right-clicking on the movie
panel and then selecting Show > Distribution). If the orange overlay shows clear hotspots, these regions
may be a candidate to be removed. Ideally, the orange overlay should be fairly homogenous.

Nearest neighbour selection

The Nearest Neighbour tab allows you to adjust the minimum allowable distance (in pixels) between neigh-
bouring events. Events that are closer together than the set value will be removed from the histogram.

Mass calibration
How to generate a mass calibration

Precise calibration of the contrast value and mass of a protein is required for accurate mass determination.
This procedure is performed during instrument installation and is repeated periodically at a frequency to suit
the needs of each user. It is recommended that mass calibration is performed before measurements requiring
high mass accuracy.

The mass calibration relies on measurements of several proteins of known mass, or a standardised protein
mixture. Full details of the laboratory procedure can be found in the user manual for the mass photometer.
This section of this manual assumes that the correct steps have been taken to measure a set of proteins on
one of Refeyn’s mass photometers. In our example, we show the results of measuring the Refeyn Standard
Protein Mixture for Mass Calibration.

After analysing a mass calibrant protein in Discover', histogram peaks are observed at/or near the expected
positions on the contrast axis. The peaks can be labelled with either vertical lines, interval regions or Gaussian
fits (Gaussian fits in histogram mode only).
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Figure 15: Gaussian peak fits in contrast mode

Clicking the Create Mass Calibration button found in the Analysis Panel will open the mass calibration
dialog. In the dialog, the contrast values for each of the peaks, interval regions, and vertical lines added in the
last step will automatically be shown in the mass calibration table. The dropdown box of calibrants can then be
used to choose known mass values. If the calibrant used is not listed, its mass can be entered manually. When
there are mass calibrants that are used often, the values can be added and saved under Manage Calibrants.

Discover™? will fit a straight-line calibration through the points entered in the table. Two measures are used
to characterise the match of data and the obtained mass calibration:

1. Maximum mass error: Maximum percentage difference between the given mass value and the mass value
calculated from the calibration

2. r? value for all data points

Mass errors for any individual data point can be found by hovering over the point in the graph.
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® Mass Calibration - 2019_07_17-10_12_03 X
Add from file... Remove Gradient [kDa]: - &  Y-intercept:

Contrast

MM 3
MM 4

Manage Calibrants Save Cancel

Figure 16: Mass calibration dialog

s =~ Ensure that the fitted calibration curve (yellow line) is visibly a good fit to the calibration
.' data. If it is not, check for entry errors in the mass calibration table, or repeat the calibration
= = measurement(s).

After a calibration has been generated it will be automatically added to the Mass Calibration Panel.

Applying a mass calibration

To apply a mass calibration to one or more measurements, first select the measurement file(s) to which you
wish to apply the calibration and then double-click on the mass calibration listed in the Mass Calibration
Panel.

To remove a mass calibration from one or more measurements, first select the measurement file(s) from which
you wish to remove the calibration and then double-click on No calibration in the Mass Calibration Panel.

You should not use a mass calibrations derived from a movie with one image size for a sample movie with a
different image size. For example, if the mass calibration was created from a movie recorded with the Regular
image size in Acquire™”, it should not be used for a sample movie that was recorded using the Large image
size.

\ ! 4
_._ When clicking on a measurement file, the applied mass calibration will be highlighted in bold.

=~ |f no mass calibration is applied, No calibration in the Mass Calibration Panel will become bold.

Managing the mass calibration panel

To add a mass calibration, you can generate a new mass calibration (see above) or press the + button to open
a previously saved mass calibration file (.mc).
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To remove a mass calibration from the panel, select the mass calibration and click the Bin icon in the Mass
Calibration Panel.

\ ! 4
__ All mass calibrations in the Mass Calibration Panel will be automatically saved as mass calibra-

\=f~ tion files (.mc) when saving the workspace.

Figures

Generating a new figure

Figures can be generated using one or multiple measurement files opened in the workspace. To generate a
new figure, go to the Figures Panel > Add Figure > Stacked Histograms or 3D Histogram. More
than one figure can be created in the same workspace.

Once a figure is generated, Setup is automatically opened. Here you can define the figure title and the limits
and units of its axes. Changing the figure title under Setup will automatically change the name on the figure
tab. Figure setup can be accessed at any time by pressing Setup.

X axis units:

» Ratiometric Contrast
* Mass [kDa] or [MDa]

Y axis units:

* Stacked histogram:

Counts

Normalised Counts
Density (KDE)

= Normalised Density (KDE)

* 3D Histogram:

-~ Legend names
Z axis units:

* 3D histogram:

Counts

Normalised Counts
Density (KDE)

Normalised Density (KDE)

\ ’
__ Please note that mass is only available if a mass calibration has been applied to the chosen
s measurement files.
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Defining a figure

Under Style, you can define which elements will be displayed in the figure and can edit its formatting. After
selecting an item under Style, formatting options will be displayed in the panel below. You can also remove
elements (such as the title) from the figure by ticking or unticking them.

Formatting options available for figures:

* Figure: Background colour; figure size

* Title: Font type, colour and size

» Axes: Font type, colour and size; Major and minor ticks

» Labels: Font type, colour and size, label content

* Legend (only stacked histogram): Font type, colour and size; legend title
* Grid: Axis of grid, thickness, position and colour of grid lines

\ 4
_ Formatting of labels will apply to labels for all overlays: vertical lines, interval regions, Gaus-
s sian fits and AAV limits.

Adding and removing measurement files

To add one or more measurements to a figure, select the measurement files in the Files Panel, then drag
and drop the files into the Figures Panel. To remove a measurement file, select it and click on Remove.
Measurement files removed from the workspace will automatically be removed from the Figures Panel.

The relative position of the plots in the figure can be changed by changing the order of the listed measurement
files in the Figures Panel. The order of measurement files can be changed by dragging and dropping the files
or by right-clicking and choosing the relevant option.

Formatting individual measurements

Each measurement file added to a figure will show a list of its associated overlays (vertical lines, Gaussian
fits, intervals and AAV limits). By default, all overlays will automatically be shown in the figure. Please note
that overlays must first be created in the Analysis Panel. Removing an overlay from the Analysis Panel will
automatically remove it from the Figures Panel as well. An overlay can be removed from the figure by unticking
it in the list. This will have no impact on the Analysis Panel.

Formatting options available for individual datasets:

* Filename: legend name

* Histogram: fill colour, line pattern, line colour, line thickness

» Gaussians: peak line colour, peak line thickness, combined line colour, combined line thickness, label
colour

* Vertical lines: line colour, line thickness, label colour

* Intervals & AAV regions: fill colour, label colour
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Figure (1)

Figure 17: Figure generation in Figures Panel

Figure themes

Figure settings can be saved as a theme and edited under Edit themes. If you want to generate a theme
from an already made figure you can select Generate theme from figure this will automatically populate
all the settings in the figure in a new theme. The themes can be shared by using export and import theme.
When setting a theme as default every new figure will automatically have those settings applied. To apply a
previously saved theme you can select a theme under Choose theme.

Formatting options avaiable for themes:

* Figure: Background colour; figure size

* Title: Font type, colour and size

» Axes: Font type, colour and size; Major and minor ticks

+ Labels: Font type, colour and size

* Legend (only stacked histogram): Font type, colour and size; legend title

* Grid: Axis of grid, thickness, position and colour of grid lines

* Colours: the fill colour, fill patern, line colour and line thickness can be chosen for the first ten mea-
surements in a figure

® Histogram Themes Editor =

Figure Title Axes Labels Gri

Make default )

Figure 18: Histogram Themes Editor dialog
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Tables

Generating a new table

Figures can be generated using one or multiple measurement files opened in the workspace. To generate a new
figure, go to the Tables Panel > Add Table > pdf - limited to 24 measurements or csv - unlimited
measurements. More than one table can be created in the same workspace.

The columns of both the pdf and csv table are customisable and can be saved as a template. The column
options contain all the histogram overlay information as well as additional information for making decisions
about the data.

Both the column and the row order of the tables can be changed by changing the order in the applied columns
and measurements panel.

Saving and exporting

Saving workspaces

After running the analysis, a full record of the measurement files, analysis results and figures generated can be
saved in the form of a Workspace. To save a workspace go to File > Save Workspace. This will open a
dialog where the save location can be chosen. The workspace consists of a folder containing:

* A workspace file (.dmp)

* A mass calibration folder, containing all the mass calibration files (.mc)

* One or more mass photometry results files (.mpr), one for each measurement file opened in the
workspace

Exporting a figure or table

To export a figure from the Figures Panel or table from the Table panel, press the Export button located at
the top-right of the Panel. This will open a dialog where you can choose to export the current figure or table
or all figures or tables and a file format. You can choose to save figures as PNG, SVG, PDF or EPS and tables
as csv, pdf or png.

Exporting Summary report

To export a pdf report combining pdf tables and figures press the report button. In the Summary report
dialog there is the option to choose which tables and figures to include and in which order. There is as well
an option to include comments. When finished press on generate report this will open a dialog where you
can choose the save location and filename.
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Exporting results and analysis data

To export data related to individual measurement files, right-click on the measurement file, then press
Export and select one of the following options:

* Results

* Events

* Single measurement report

* Movie

* Figure

* Scores

* Raw frames; native or ratiometric

Batch export is also possible by selecting multiple measurements instead of a single measurements before
right-clicking.

Results To export individual measurement results files (.mpr). This will open a dialog where the save location
can be chosen.

\ ! ’

__ Mass photometry results files (.mpr) will automatically be generated when saving the entire
=/ workspace.

Single measurement report A single measurement report detailing the acquisition and analysis settings
for a given set of results can be exported. This will bring up a window showing the value of every setting.
The right-hand “Description” column can be removed by unticking the box at the top of the dialog labelled
Include descriptions. To save the report, press the Export button and choose a file format. Reports can
be saved as PDF, CSV or JSON.
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#® Report x

Include descriptions

Analysis

Info

Figure 19: An example of a report

Events The mathematical algorithm for finding binding and unbinding events is a two-stage process that first
detects step changes of the glass reflectivity and then assesses whether the respective peak in the ratiometric
image matches the expected signature. The original data generated by this algorithm can be exported as a
.csv or .h5 file.

Frames This options allows for the export of all frames from a movie. Users can choose between exporting
ratiometric or native moves by pressing Export > Raw Frames > Ratiometric or Native as desired. This
will generate a .h5 file. Additionally, it is possible to export a single frame from a movie. For this, a users is
required to go to the Analysis Panel, right-click on the movie and press Export frame. This will export the
currently displayed frame as a PNG or PDF file.

Movie Movies generated can be exported as a MP4, MOV, AVI or TIFF. When exporting a movie, an additional
dialog will open with the following options:

* Movie: Which movie to export (native or ratiometric).

Start/Stop Frame: The range of frames to export.

* Upscale: this causes the movie to be saved at a higher resolution (without interpolation).

* Frame Rate: the number of frames played per second.

* Colormap: this shows the colours that will be used to represent high and low values.

* Colorbar: when ticked this adds a colorbar to every frame of the movie to show the contrast scale.
» Annotate Frames: when ticked, this adds a label to each frame indicating the frame number.

Note: TIFF format only uses the start and stop frame values. The other settings have no impact on the TIFF
format. This will open a dialog where movie options can be selected.
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® Export Movie - NM_1 .

Movie ratiometric
Start Frame

6000

Frame rate / Hz
Colormap
Colorbar

Annotate Frames

Export

Figure 20: Export movie dialog

Making the movie larger using third party software (e.g. Windows Media Player), may result
: in interpolation that reduces accuracy and blurs images. It is preferable to perform this

\ 4
“ operation at the time of exporting the movie. The recommended value for upscaling is 3.
= = The larger the upscale value, the larger the exported file will be and the longer it will take

to export.

Scores Data on brightness, motion, sharpness, saturation and signal can be exported as a .h5 file.

Exporting mass calibrations

After a mass calibration is added to the Mass Calibration Panel it can be exported as a mass calibration file
(.mc) by selecting the mass calibration and clicking on the Export icon on the Mass Calibration Panel.

Additional functionality

Analysis comments

It is possible to save comments to a set of Discover™ results. When a movie has been loaded, the comments
button located in the top right corner of the Analysis Panel can be pressed. This opens a dialog with two
tabs. The first tab is Analysis. These are comments that should relate to the information from Discover™.
The second tab is Acquisition, which displays the sample information and comments provided in Acquire™”
when the movie was recorded. These comments will be included in a generated report.
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Enter analysis comments

Figure 21: Comments dialog displaying an example comment

Tooltips

Discover™ includes tooltips which may be displayed by hovering over buttons. These explain the use and

purpose of each button.

What’s this

Discover™P application includes What’sThis boxes which may be displayed by clicking the Question Mark
button (found at the top right of dialogs and windows) and then clicking on a Ul element, such as a button
or tickbox. These boxes will contain detailed information about the element in question.

Analysis settings for One™P users

One™P users have access to an additional settings dialog which enables changes to the analysis pipeline. Settings
apply to individual measurement files. To access settings, go to the File Panel, right-click on the desired
measurement file and select Settings

Analysis can be split up into two stages: the finding of events and the fitting of events.

Finding events: The mathematical algorithm for Finding Events is a two-stage methodology that first detects
step changes of the glass reflectivity (Filter 1) and then assesses whether the respective peak in the ratiometric
image matches the expected signature (Filter 2).

Fitting events: This takes the found events and fits a Point Spread Function to the events. The position of
the best fit will become the center of the event.

The settings used for threshold 1 and 2 in the analysis have been described above. The default values should
be appropriate for most cases, but expert users may wish to adjust them. To return to the default settings at
any time, select Reset in the Settings dialog.

The value for Number of Binned Frames defines the number of native frames that are averaged during
the calculation of a single ratiometric frame. Increasing this value from 5 to 6 or 7 usually decreases noise and
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enhances the sensitivity for the detection of low-mass particles. However, increasing it also leads to more
crowded ratiometric frames, especially for concentrated samples. The associated signal overlap may lower
sensitivity and mass precision.

The Reflectance Correction when ticked will apply Refeyn’s algorithm to reduce signals that can be pro-
duced by the reflection of the glass surface.

The Motion Correction when ticked will apply Refeyn’s algorithm to reduce artefacts in the ratiometric
contrast images that are an effect of the transverse motion of the microscope slide, either due to drift or an
external vibration source. The algorithm estimates the amplitude of the motion signature in the ratiometric
frame and subtracts it.

An advanced settings feature is available when selecting Advanced in the Settings dialog. We advise users to
not change advanced settings unless instructed to do so by Refeyn.

Preferences

Discover™ has a small set of preferences that the user can interact with via File > Preferences.

When enabling Show mass calibration help, Discover™" will show a dialog explaining how to apply a mass
calibrations when a mass calibration file is opened for the first time.

When ticking the Use experimental quality filtering, an experimental analysis pipeline will be enabled.
We suggest this feature to be disabled unless advised by Refeyn’s team.

If the Send usage data box is ticked, Discover' will report basic data about the user’s use of the software
to Refeyn, including error reports.
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General information

Refeyn Ltd service and support
Refeyn Ltd offer service and technical support for our mass photometry systems, and the Refeyn Acquire™”
and Refeyn Discover™? software applications:

Refeyn Ltd

Unit 9, Trade City

Sandy Lane West

Oxford

OX4 6FF

Email: support@refeyn.com
Call: +44 (0) 1865 800 175

Disclaimer

This user guide is proprietary to Refeyn Ltd and no part of this manual may be reproduced, copied or duplicated
without the express written permission of Refeyn Ltd.

The information contained in this user manual is intended solely for informational purposes and is subject to
alteration without warning and does not represent a commitment on the part of Refeyn Ltd. This user manual
has been prepared by Refeyn Ltd in good faith, through exercising due and customary care and on the basis of
information available at the date of publication and Refeyn makes no commitment to update or keep current
the information in this user guide. Refeyn Ltd reserves the right to make improvements to this user guide
and/or to the products described in this user guide, at any time without notice. For this reason, users should
not act upon any information contained herein without first consulting Refeyn Ltd.

Whilst every effort has been made to ensure that this user guide is accurate, Refeyn makes no warranty, ex-
press or implied in relation to the contents of this document and does not guarantee or warrant the accuracy,
reliability, completeness or currency of the information in this user guide, nor the quality, performance, mer-
chantability or fitness for a particular purpose of the product described herein or that the product will work
in all applications or environments. Refeyn Ltd therefore assumes no liability for any loss, damage, cost or
expense incurred or arising by reason of any person using or relying on information in this report or for any
errors, omissions or misrepresentations contained therein.
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